MSRPRelay version 1.0.2

MSRPRelay version 1.0.2 has been released, it contains various bug fixes and compatibility with newer software.

For more information visit

To upgrade your debian installation:

sudo apt-get update
sudo apt-get install msrprelay

Or download the tar file from:

The changelog follows:

msrprelay (1.0.2) unstable; urgency=low

  • Adapted code to work with the latest python-application changes:
    • use ConfigSetting descriptors instead of _datatypes
    • replaced startSyslog with start_syslog
    • use system_config_directory instead of _system_config_directory
  • Added runtime dependency checks using application.dependency
  • Small fix in forwarding logic
  • Improved error messages when TLS certificates are missing or faulty
  • Added log_level option to configuration file
  • Fixed debian building warnings
  • Update sample config file
  • Moved tasks to wiki tickets
  • Fixed parameter quoting in WWW-Authenticate and Authentication-Info header
  • Added relay session_id check for incoming messages
  • Use os.urandom instead of reading directly from /dev/urandom
  • Allow refreshing AUTH from client, nothing is actually refreshed
  • Fixed the first characted of generated transaction-id to be alphanumeric
  • Correct callback sequence for authentication Deferred
  • Updated debian dependencies
  • Updated dependencies in INSTALL
  • Removed unused imports
  • Minimized and updated build and runtime dependencies
  • Removed obsolete python version specifications in debian control file
  • Added missing files to source distribution
  • Fixed lintian warning about missing misc:Depends